pip安装错误“没有这样的文件或目录:setup.py”
python
tensorflow
5
0

我收到安装错误,因为pip找不到setup.py。

sudo pip install https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.5.0-cp27-none-linux_x86_64.whl

我收到此错误消息。

Downloading/unpacking https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.5.0-cp27-none-linux_x86_64.whl
Downloading tensorflow-0.5.0-cp27-none-linux_x86_64.whl (10.9Mb): 10.9Mb downloaded
Running setup.py egg_info for package from https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.5.0-cp27-none-linux_x86_64.whl
Traceback (most recent call last):
File "<string>", line 14, in <module>
IOError: [Errno 2] No such file or directory: '/tmp/pip-GdGgbz-build/setup.py'
Complete output from command python setup.py egg_info:
Traceback (most recent call last):

File "<string>", line 14, in <module>

IOError: [Errno 2] No such file or directory: '/tmp/pip-GdGgbz-build/setup.py'

谁能告诉我如何解决这个问题?

谢谢。

参考资料:
Stack Overflow
收藏
评论
共 3 个回答
高赞 时间 活跃

尝试通过pip install升级protobuf:

sudo pip install --upgrade protobuf 
sudo pip install --upgrade https://storage.googleapis.com/tensorflow/mac/protobuf-3.0.0b2.post2-cp27-none-any.whl

为我工作。该文档为各种安装问题提供了许多解决方案。

收藏
评论

来自https://github.com/tensorflow/tensorflow/issues/56

键入的命令是“ pip install --upgrade pip” ,应该在指令告诉用户“ source bin / activate”之后立即添加到说明中

收藏
评论

Tensorflow需要python -V 2.7。由于很多机器都使用稳定的2.6 python版本进行系统构建,所以我建议并行/替代安装python 2.7。然后,您可以使用2.7版python解释器安装pip。请看下面:

#sudo wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
#sudo python2.7 ez_setup.py
#easy_install-2.7 pip
#sudo pip install https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.5.0-cp27-none-linux_x86_64.whl
收藏
评论
新手导航
  • 社区规范
  • 提出问题
  • 进行投票
  • 个人资料
  • 优化问题
  • 回答问题

关于我们

常见问题

内容许可

联系我们

@2020 AskGo
京ICP备20001863号