找不到满足需求张量流的版本
python
python-2.7
python-3.x
tensorflow
17
0

我安装了最新版本的Python (3.6.4 64-bit)和最新版本的PyCharm (2017.3.3 64-bit) 。然后我在PyCharm中安装了一些模块(Numpy,Pandas等),但是当我尝试安装Tensorflow时却没有安装,并且出现了错误消息:

找不到满足TensorFlow要求的版本(来自版本:)找不到与TensorFlow匹配的发行版。

然后我尝试从命令提示符下安装TensorFlow,并得到了相同的错误消息。但是,我确实成功安装了tflearn。

我还安装了Python 2.7,但又收到了相同的错误消息。我搜索了该错误,并尝试了一些建议给其他人的方法,但是没有任何效果(包括安装Flask)。

我该如何安装Tensorflow?谢谢。

参考资料:
Stack Overflow
收藏
评论
共 10 个回答
高赞 时间 活跃

如果您使用anaconda ,则默认情况下会安装python 3.7,因此您必须将其降级为3.6:

康达安装python = 3.6

然后:

点安装tensorflow

它在Ubuntu中为我工作。

收藏
评论

我通过pip install https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.8.0-py3-none-any.whl成功安装了它

收藏
评论

我在ubunu 18.04上使用python 3.6.8,对我来说解决方案是只升级pip

pip install --upgrade pip
pip install tensorflow==2.1.0
收藏
评论

我正在为Windows提供它

如果您使用的是python-3

  1. 使用py -m pip install --upgrade pip升级到最新版本py -m pip install --upgrade pip
  2. 使用py -m pip install <package-name>

如果您使用的是python-2

  1. 使用py -2 -m pip install --upgrade pip升级到最新版本py -2 -m pip install --upgrade pip
  2. 使用py -2 -m pip install <package-name>

对我有用

收藏
评论

卸载Python然后重新安装解决了我的问题,并且我能够成功安装TensorFlow。

收藏
评论

安装Tensorflow有两个重要规则:

  • 您必须安装Python x64 。它在32b上不起作用,并且给出与您相同的错误。

  • 支持最新版本的Python3 = 3.7。

例如,您可以安装Python3.6.2-64bit ,它的工作原理类似于Charm。

收藏
评论

看起来问题出在Python 3.8上。请改用Python 3.7。我已采取步骤解决此问题。

  • 使用conda创建了python 3.7环境
  • 列表项在环境中使用pip install rasa安装了rasa。

为我工作。

收藏
评论

根据Tensorflow的文档页面,不适用于python 3.8 (截至2019年12月4日)。您将必须降级到python 3.7

收藏
评论

不支持Python版本卸载python

https://www.python.org/downloads/release/python-362/

您应该在安装页面中检查并使用确切的版本。 https://www.tensorflow.org/install/install_windows

python 3.6.2或python 3.5.2为我解决了这个问题

收藏
评论

截至2018年8月13日的Tensorflow支持Python 3.6.x和仅64位版本。

收藏
评论
新手导航
  • 社区规范
  • 提出问题
  • 进行投票
  • 个人资料
  • 优化问题
  • 回答问题

关于我们

常见问题

内容许可

联系我们

@2020 AskGo
京ICP备20001863号